


Copyright © 2012 by Celartem, Inc. dba Extensis. All rights reserved.

Disclaimer: Fonts are software and are subject to license restrictions. Any recommendations in this guide regarding moving and using fonts should 
be considered with respect to the license included with the fonts.

Contents
Why do you need to manage fonts? ................................................................................................................................................................1

About this guide ...............................................................................................................................................................................................1

Conventions ..............................................................................................................................................................................................1

Font management best practices ................................................................................................................................................................... 2

Use a font management application ....................................................................................................................................................... 2

Collect your fonts ..................................................................................................................................................................................... 2

Plan for new font installations ................................................................................................................................................................ 2

Choosing a font management application ..................................................................................................................................................... 2

Basic functionality of a font manager..................................................................................................................................................... 2

Gathering your fonts ....................................................................................................................................................................................... 5

Back up your system ................................................................................................................................................................................ 5

Pare down your system fonts .................................................................................................................................................................. 5

Upgrade old fonts ....................................................................................................................................................................................10

Adding fonts to your font manager .......................................................................................................................................................10

Identifying duplicates ............................................................................................................................................................................. 12

Finding corrupt fonts .............................................................................................................................................................................. 14

Planning for more fonts ................................................................................................................................................................................. 15

Where fonts come from .......................................................................................................................................................................... 15

Purchased fonts ....................................................................................................................................................................................... 15

Fonts included with applications ........................................................................................................................................................... 15

Font caches .............................................................................................................................................................................................. 17

It never ends ................................................................................................................................................................................................... 17

Appendix A: Font terminology ...................................................................................................................................................................... 18

Appendix B: The User Library under Lion and Mountain Lion .................................................................................................................. 20

Appendix C: Clearing font caches manually ................................................................................................................................................. 21

Appendix D: Font formats .............................................................................................................................................................................23

Appendix E: Color-coding fonts ................................................................................................................................................................... 26

Extensis ...........................................................................................................................................................................................................27



1

Best Practices Guide
Why do you need to manage fonts?
If you are a design professional—if you create documents or graphics or do any of the 
1,001 other things that designers do on computers—you probably have hundreds or 
even thousands of fonts. You probably use the same group of fonts for a specific set of 
projects, and you may have different versions of the same font for different clients.

You need to be aware of your fonts, know where they are, and know how and when to 
use them.

Here are some of the reasons that you need to manage your fonts:
 ▶ Different projects may require different versions of the same font. This can be 
especially true if you are working on projects for multiple clients.
 ▶ Fonts use system resources, so the more fonts you have loaded, the less you can do 
with your computer.
 ▶ Applications that you install could make changes to your fonts without your 
knowledge.
 ▶ Tracking down corrupt fonts can take valuable production time.
 ▶ When you have a lot of fonts, the Font menus in your applications can take a long 
time to scroll through. (Some people would put this at the top of this list.)

If you have a large collection of fonts, effective font management is critical.

Using a font manager can help with all these and provide additional benefits, such as:
 ▶ You can search and compare fonts to find the best one for the job at hand.
 ▶ You can quickly build font previews for client approval.
 ▶ See how new fonts will work within existing web projects.

About this guide
This guide is designed to help Macintosh users understand more about managing their 
fonts. It contains recommendations and instructions that can help you configure your 
system to minimize font problems and improve your work efficiency. It covers:

 ▶ Choosing a font manager
 ▶ Collecting your fonts
 ▶ Dealing with duplicate and corrupt fonts
 ▶ Planning ahead for new fonts

Conventions

Because much of the information in this guide is technical in nature, it is important to 
present that information clearly and unambiguously. We use the following conventions 
to help convey exact meaning:

 ▶ Code font: text that you are to type (such as in a Terminal session) is shown in this 
typeface.
 ▶ File names: When possible, we’ll give exact file names, including their extensions.
 ▶ Files and folders: File and folder name and paths are shown in this typeface. When 
we present a full path, it will start with a slash character / indicating the root of 
the hard disk, such as /Library/Fonts/. A relative path will start with a base folder 
name, such as My Fonts/System Fonts/. Paths that start in the current user’s home 
directory are given using the tilde ~ character: ~/Library/Fonts/ is equivalent to 
/Users/currentUser/Library/Fonts/. A path that ends with a folder name will end 
with a slash, whereas a path that ends with a filename will not. Individual file and 
folder names will be identified in the text (the Fonts folder; the file Andale Mono).

Is there more than one of you?
If you manage multiple users in a workgroup, 
you may benefit significantly from the use of a 
server-based font management system, such as 
Universal Type Server. To download white 
papers, documentation and related information 
about the benefits of server-based font 
management solutions, please visit the Extensis 
website at http://www.extensis.com/
universal-type-server-3/.

http://www.extensis.com/universal-type-server-3/
http://www.extensis.com/universal-type-server-3/
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Font management best practices
A good font manager should be almost invisible in your workflow, so that font 
activation and deactivation takes place without your intervention.

Most of the remainder of this guide is devoted to discussing the following Best Practices.

Use a font management application

A good font manager can address all of the aforementioned issues and provide 
additional utility as well. Depending on your needs, you can get a font manager for an 
individual computer or a server-based solution that can manage fonts for groups or 
teams within your organization.

Collect your fonts

To effectively manage your fonts, you should strip down your system to the basic 
required fonts, eliminate duplicates, identify and replace corrupt fonts, upgrade very old 
fonts, and add them to your font manager.

Plan for new font installations

When you buy new fonts or software that includes fonts, you should take steps to add 
the fonts to your font management solution.

Choosing a font management application
There are several professional font management applications available. You should 
evaluate what you need a font manager to do. Although OS X has basic font 
management functionality available through its Font Book application, for design 
professionals, the Mac’s built-in font management capabilities don’t go far enough.

Basic functionality of a font manager

A font manager’s main purpose is to make fonts available when they are needed, and 
remove them from use when you are done with them.

When a font is available for use, it is called an active font, and the process of making it 
available is called activation. When the font is removed from availability, it is 
deactivated. This is the major feature of a font manager and other capabilities revolve 
around the notion of activating and deactivating—or managing—fonts.

Some important features to look for in a font manager are:
 ▶ Ability to manage fonts in System font folders
 ▶ Ability to manage user-specified sets of fonts
 ▶ Ability to automatically activate fonts used in a document you open
 ▶ Ability to handle special required System fonts
 ▶ Works in the background with no user intervention necessary

Other features that can help your workflow include:
 ▶ Ability to preview fonts in multiple configurations
 ▶ Ability to print font specimens
 ▶ Ability to search for fonts based on any of several criteria
 ▶ Ability to store fonts in a common, protected location
 ▶ Ability to activate fonts in place, without moving them
 ▶ Ability to collect fonts for redistribution
 ▶ Ability to troubleshoot fonts
 ▶ Ability to clean system and application font caches

What about Font Book?
While Font Book provides basic font 
management capabilities, it doesn’t have the 
flexibility of a professional font manager.

However, even though you won’t use it for your 
font management needs, don’t delete it. Font 
Book is integrated with OS X.

See Adding fonts to your font manager on 
page 10 for details on disabling Font Book’s 
font management to avoid conflict with your 
chosen font manager.
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Manage fonts in OS font folders
The Mac OS has several locations where it normally stores and looks for fonts. On a 
typical system, there will be three folders where fonts may be stored:

 ▶ The System fonts folder, /System/Library/Fonts/
 ▶ The Local fonts folder, /Library/Fonts/
 ▶ The User fonts folder, ~/Library/Fonts/

The System fonts folder is generally reserved for fonts required by the Mac OS and 
shouldn’t be modified casually. The Local fonts folder is where other generally available 
fonts are stored. The User fonts folder holds fonts that are private for each user; if your 
computer has two user accounts Joe and Mary, there can be fonts in /Users/Joe/
Library/Fonts/ that are only available to Joe, and fonts in /Users/Mary/Library/Fonts/ 
that are only available to Mary.

A good font manager will identify and separately manage fonts in these locations.

Note: OS X Lion and Mountain Lion hide the user Library folder (and hence 
the Fonts folder as well). For more information, see Appendix B: The User 
Library under Lion and Mountain Lion on page 20.

Manage sets of fonts
By the time you get your computer set up and software installed, you will have several 
hundred—and possibly thousands—of fonts.

Many designers find it convenient to group fonts they use for certain tasks, either by 
client or by job. This makes it easy to activate, deactivate, and collect the fonts you need 
when you need them.

Automatic font activation
One of the nicer features of font managers is the ability to detect the fonts used in a 
document and automatically activate them when you open that document.

This type of activation is based on the font information available in the document—
usually the font’s PostScript name. While this is convenient, it can occasionally activate 
a different version of a font than the one you expect.

Most commercial font managers include a second, more robust form of automatic 
activation that relies on plug-ins installed for certain applications—typically design 
applications like Photoshop and QuarkXPress. The plug-in looks at additional 
information about fonts used in the document in order to determine the correct font to 
activate. This makes it possible for the font manager to activate the same font (and 
more importantly, the correct font) consistently in each document.

Conflicting System fonts
The operating system identifies fonts by a name that is internal to the font. A conflict 
occurs if there are two fonts that are active that have the same internal name.

Two required System fonts on OS X, Helvetica and Helvetica Neue, have the same 
internal name as their PostScript Type 1 counterparts. Many designers need to use 
PostScript Type 1 fonts, but OS X goes to great lengths to see to it that it versions of 
these fonts don’t get disabled or removed.

A good font manager will recognize the need to use different versions of these System 
fonts and correctly handle the activation for you.

Background operation
To make font management a mostly hands-off process, most font managers include a 
background component that is always running; it does all the font activation and 

Other System font folders
There is a fourth location where fonts can be 
stored on OS X: in /Network/Library/Fonts/. 
This location is for fonts shared on a network 
that are managed manually. If you find that you 
need to share fonts on a network, rather than 
install local copies, you would most likely benefit 
immensely from a server-based font 
management solution.

In older versions of Mac OS X that supported the 
Classic environment (which allowed running 
programs designed for Mac OS 9), fonts could 
also be located in /System Folder/Fonts/. 
Classic was only available for Macs with a 
PowerPC processor; support ended for PowerPC 
Macs with OS X v10.5. (Note that later versions 
of OS X—including Mountain Lion—can still 
use fonts designed for the Classic Mac 
environment; they just need to be added to your 
font manager, or installed in the User or Local 
fonts folder.)
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deactivation work automatically. You only need to use the application’s interface to 
perform specific tasks like creating sets or comparing fonts side by side.

Font preview and printing
When you choose a font for a project, one consideration is how the font looks and acts: 
the shape and relative size of the glyphs, character and line spacing, and so on. A good 
font manager will let you look at font samples under many conditions: with your own 
sample text, in multiple sizes and styles, and even in the context of your project.

In addition to previewing fonts, many designers like to keep a type specimen book, both 
for their own use and for clients to peruse. An added benefit of some font managers is 
the ability to print custom font specimens.

Searching for fonts
When you have thousands of fonts available, it can seem overwhelming to try to find 
the right one, or to decide between a few. A good starting point can be to narrow the 
field using a search with multiple criteria.

A font manager can limit the list of fonts by name, classification, style, foundry, or other 
criteria, so that you can easily see a subset of your fonts.

Private font storage and in-place activation
In order to keep your fonts safe as well as easy to maintain, font managers offer the 
option of copying your fonts to a private folder, where the application can activate them 
but where they are safe from casual outside access. This gives the advantage of keeping 
all your fonts in one place and keeping them separate from required OS fonts.

There may be times when you need to make sure that some fonts are not added to your 
main collection, for instance if you have a client that requires segregating their fonts 
from others. In this case, your font manager also needs to provide the ability to activate 
fonts that remain outside of the private font store, usually called in-place activation.

Collecting fonts
Font managers will usually allow you to select fonts and copy them to another folder 
for use elsewhere, either to install on another computer or to deliver to a print shop 
with a document. (Carefully read your font or software license to determine what you 
can and cannot do with fonts.)

Font troubleshooting
Fonts, like any other file on your computer, can become corrupted even though you do 
everything “right.” If you experience odd behavior related to how text is displayed, you 
could have a corrupt font.

Font managers can look inside a font to determine if it has gone bad. Some will even 
scan fonts for issues when you install them, rather than let you find out later that a font 
is corrupt.

Cleaning font caches
OS X and many applications use a font cache for both of these reasons: to quickly 
access fonts that are frequently used, but to keep the files inaccessible to other 
applications. Files in a font cache can become damaged just as any other file can. If a 
font appears garbled or you start to have other font-related issues, you may have a 
corrupt cache.

A good font manager will be able to clear the font caches for OS X as well as your design 
applications.
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Gathering your fonts
Before you start managing your fonts, it is a good idea to get them together, separate the 
wheat from the chaff, and make backup copies. The process you use will be similar 
whether you are starting from a “clean” system (either a new purchase or a computer 
that has been wiped and had the operating system re-installed), or you are working 
with a production system that already has software and fonts installed.

The steps in preparing your fonts to be managed are:
 ▶ Back up your system
 ▶ Pare down your system fonts
 ▶ Upgrade old fonts
 ▶ Add fonts to your font manager
 ▶ Find and remove duplicate fonts
 ▶ Find and replace corrupt fonts

Back up your system

Before embarking on any project that requires you to move or delete files or install new 
software, you should make sure that your computer is adequately backed up so that, if 
something goes wrong, you can return your system to its previous state.

You should also make a backup of your system fonts as a secondary precaution.
1. Make a folder on the Desktop named System Fonts and another folder named 

Local Fonts. 
2. Open the /System/Library/Fonts/ folder.
3. Select all the fonts, hold down the Option key, and drag the fonts to the 

System Fonts folder on the desktop.
4. Open the /Library/Fonts/ folder and Option-drag all the fonts to the 

Local Fonts folder on the desktop.
5. Select the System Fonts and Local Fonts folders on the desktop and choose 

File > Compress 2 Items. 
This will create a compressed file named Archive.zip on the desktop.

6. Rename the file Archive.zip to Original Fonts.zip.
7. Copy the Original Fonts.zip file to two external devices (CD, DVD, USB hard 

drive, network volume, thumb drive, cloud storage, etc.). 
Two backups of important data are better than one.

Once you have copied your archive to backup media, you can delete the Original 
Fonts.zip file and the System Fonts and Local Fonts folders from your Desktop.

Pare down your system fonts

The first step in getting your fonts ready to be managed is to remove all unnecessary 
fonts from your computer’s System font folders.

Unless you are using software that depends on a very specific version of OS X, you 
should make sure that your operating system and its included applications are up-to-
date. Click the Apple menu and choose Software Update; if any updates are found, 
install them. This will ensure that, among other things, your system fonts are all 
up-to-date.

We are going to separate the fonts on your computer into the following categories:
 ▶ Fonts required by OS X or one of its integral applications
 ▶ Fonts required by OS X under uncommon circumstances
 ▶ Fonts required by Apple-supplied applications that come with OS X
 ▶ Core web fonts
 ▶ Optional fonts

What extension, please?
Often, you will need to differentiate between font 
files that have an extension (such as the .ttf in 
Arial.ttf) and those that do not. To do this, you 
will need to enable file extensions in the Finder:
1. Choose Finder > Preferences.
2. Click the Advanced icon.
3. Enable Show all filename extensions 

(Show all file extensions in OS X 10.5).
4. Close the Finder Preferences window.

This shows the extensions of all your files, not 
just your font files: .doc or .docx for Word files, 
.app for applications, and so on. If you find this 
distracting, you can disable filename extensions 
in the Finder Preferences when you have finished 
gathering your fonts.
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If you have installed Adobe Creative Suite applications, we’ll separate those fonts out, 
and deal with some Microsoft Office fonts as well.

Create four folders on your Desktop: Other OS fonts, Apple app fonts, Core web fonts, 
and Optional fonts. You will move fonts into these folders from other locations on your 
hard drive.

Selecting and moving non-critical OS fonts
Important: It is generally not required that you move any fonts from 
/System/Library/Fonts/, as these are the fonts Apple deems necessary for the 
system in all languages.

If you are only using English or another Western European language, moving 
the suggested fonts should not be a problem.

If you want to be cautious, feel free to skip this step.

Open the System fonts folder, /System/Library/Fonts/ and select all the files except 
those listed below. (Some of these fonts may not be present depending on the version 
of OS X that you are running.)

 ▶ AppleGothic.ttf
 ▶ Geneva.dfont
 ▶ HelveLTMM
 ▶ Helvetica LT MM
 ▶ Helvetica.dfont
 ▶ HelveticaLight.ttf
 ▶ HelveticaLightItalic.ttf
 ▶ HelveticaNeue.dfont
 ▶ HelveticaNeueDeskUI.ttc
 ▶ Keyboard.dfont, Keyboard.ttf
 ▶ LastResort.dfont or LastResort.ttf
 ▶ LucidaGrande.dfont or LucidaGrande.ttc
 ▶ Menlo.ttc
 ▶ Monaco.dfont
 ▶ Symbol.dfont or Symbol.ttf
 ▶ Times LT MM
 ▶ Times.dfont
 ▶ TimesLTMM
 ▶ ZapfDingbats.dfont or ZapfDingbats.ttf

Drag the selected files to the Other OS fonts folder on the Desktop.

Once the files have been copied, choose File > Move to Trash to move the selected files 
from /System/Library/Fonts/ to the Trash. When prompted, enter your administrator 
password.

Moving fonts used by Apple applications
Some applications that come with OS X rely on fonts installed in the System fonts 
folder, the Local fonts folder, or both.

If you did not move fonts from the System fonts folder, then skip this paragraph. Open 
the Other OS fonts folder on the desktop. Select the following fonts and drag them to 
the Apple app fonts folder (note that some of these are not included in every version of 
OS X):

 ▶ Apple Color Emoji.ttf
 ▶ Apple Symbols.ttf
 ▶ MarkerFelt.ttc
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Open the Local fonts folder, /Library/Fonts/. Select the font file MarkerFelt.dfont or 
MarkerFelt.ttc and drag it to the Apple app fonts folder.

Collecting the Core web fonts
Many websites were designed around a common set of “web-safe” fonts that are widely 
available and are assumed to be installed on most users’ systems. It is important to 
keep these fonts available for web browsing and especially if you are a web designer.

Open the /Library/Fonts/ folder and move the following files into the Core web fonts 
folder:

 ▶ Andale Mono.ttf
 ▶ Arial Black.ttf
 ▶ Arial Bold Italic.ttf
 ▶ Arial Bold.ttf
 ▶ Arial Italic.ttf
 ▶ Arial.ttf
 ▶ Brush Script.ttf
 ▶ Comic Sans MS Bold.ttf
 ▶ Comic Sans MS.ttf
 ▶ Courier New Bold Italic.ttf
 ▶ Courier New Bold.ttf
 ▶ Courier New Italic.ttf
 ▶ Courier New.ttf
 ▶ Georgia Bold Italic.ttf
 ▶ Georgia Bold.ttf
 ▶ Georgia Italic.ttf
 ▶ Georgia.ttf
 ▶ Impact.ttf
 ▶ Tahoma Bold.ttf
 ▶ Tahoma.ttf
 ▶ Times New Roman Bold Italic.ttf
 ▶ Times New Roman Bold.ttf
 ▶ Times New Roman Italic.ttf
 ▶ Times New Roman.ttf
 ▶ Trebuchet MS Bold Italic.ttf
 ▶ Trebuchet MS Bold.ttf
 ▶ Trebuchet MS Italic.ttf
 ▶ Trebuchet MS.ttf
 ▶ Verdana Bold Italic.ttf
 ▶ Verdana Bold.ttf
 ▶ Verdana Italic.ttf
 ▶ Verdana.ttf
 ▶ Webdings.ttf

If you have installed a version of Microsoft Office, then it may have moved some of your 
fonts. Look inside the /Library/ folder for a folder named Fonts Disabled; if it exists, 
then open it and move any fonts that are on the Core web fonts list above into the Core 
web fonts folder. If you are prompted that one of the fonts already exists, replace that 
font; the one that Office disabled is the more desirable Apple font.

Gathering Adobe fonts
Create a folder on your Desktop named Adobe CS x fonts, but replace x with the version 
of your installed Creative Suite. (The original version of Creative Suite was not 
numbered but we will refer to it as Creative Suite 1.)

Did somebody say “web fonts?”
The days of web-safe fonts are not gone, but 
they are fast becoming a speck in our rear view 
mirror, thanks to web font services like WebINK.

WebINK lets you design your website using 
high-quality fonts from dozens of foundries, and 
serves those fonts to all your visitors regardless of 
the computer and browser they are using. 
(Within reason, of course; but most recent 
browsers that run on three-to-five year old 
computers or phones should work just fine.)

WebINK is also integrated into Suitcase 
Fusion 4, so you can try out fonts and do your 
prototyping in Photoshop .

Now you can finally ditch Arial and Comic Sans 
and show the world how you really feel.

Visit the WebINK website (http://www.
webink.com) for more information.

http://www.webink.com
http://www.webink.com
http://www.webink.com
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If you have Creative Suite 1:

 ▶ Open /Library/Fonts/ and move all font files whose name starts with WarnockPro 
to the Adobe CS 1 fonts folder.

If you have Creative Suite 1 or 2:
 ▶ Open /Library/Application Support/Adobe/Fonts/ and move all font files to the 
Adobe CS 1 fonts or Adobe CS 2 fonts folder. 
Be careful to leave the folder named Reqrd where it is; this folder contains fonts 
that the Adobe applications need in order to run.

Adobe CS 3 and later install fonts to the Local fonts folder. This means the Adobe fonts 
are mixed in among other installed fonts. They should still be easy to identify: all the 
Creative Suites include a version of Adobe Caslon Pro, whose filenames all start with 
ACaslonPro, and they would have all been installed at approximately the same time.

If you have Creative Suite 3 or later:
1. Open the Local fonts folder, /Library/Fonts/.
2. Choose View > As List.
3. Click the head of the column labeled Date Modified. 

This sorts the files by their modification date, which for font files is usually the 
date they were installed.

4. Find one of the fonts whose name starts with ACaslonPro. Select all the fonts 
whose Date Modified fall within a couple of minutes of this file and move 
them to the Adobe CS x fonts folder.

If you want to be more precise, check your Adobe Creative Suite CD for a list of included 
fonts, or visit these pages on Adobe’s web site:

 ▶ Fonts Installed by Adobe’s Creative Suite (http://blogs.adobe.com/typblography/
fonts-installed-by-adobes-creative-suite) 
This includes lists for CS1, CS2, CS3, CS4, CS5, and CS5.5
 ▶ Fonts included with Adobe’s Creative Suite 6 and Creative Suite 6 Applications 
(http://www.adobe.com/type/browser/fontinstall/cs6installedfonts.html)

Microsoft Office fonts
Microsoft Office installs a lot of fonts that you can use with the Office applications and 
in other projects.

Note: Microsoft Office applications build a list of available fonts when they 
start. To ensure that your documents and templates display the appropriate 
fonts, be sure to activate any required fonts using your font manager before 
you start an Office application.

Office X
The Office X applications do not require any fonts other than System fonts to run, 
though the included templates may rely on included fonts.

The Microsoft Office Installer places a set of optional fonts inside /Applications/
Microsoft Office X/Office/Fonts/; open this folder and move the fonts into the 
Optional fonts folder on the Desktop.

The Value Pack Installer places fonts in your User fonts folder. In a later step you will 
move these into the Optional fonts folder; see Gathering optional fonts on page 9.

Keeping Office up-to-date
Be sure you update your copy of Microsoft Office 
to the latest version available. For Office X, the 
last supported updater is available at http://
www.microsoft.com/en-us/download/
details.aspx?id=2415. You can update Office 
2004, 2008, and 2011 by choosing Help > 
Check for Updates in any Office application, or 
you can download updaters from http://www.
mactopia.com.

http://blogs.adobe.com/typblography/fonts-installed-by-adobes-creative-suite
http://blogs.adobe.com/typblography/fonts-installed-by-adobes-creative-suite
http://blogs.adobe.com/typblography/fonts-installed-by-adobes-creative-suite
http://www.adobe.com/type/browser/fontinstall/cs6installedfonts.html
http://www.adobe.com/type/browser/fontinstall/cs6installedfonts.html
http://www.microsoft.com/en-us/download/details.aspx?id=2415
http://www.microsoft.com/en-us/download/details.aspx?id=2415
http://www.microsoft.com/en-us/download/details.aspx?id=2415
http://www.mactopia.com
http://www.mactopia.com
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Office 2004
There are two situations with Office 2004 that need to be addressed:

 ▶ The first time you run an Office application, Office 2004 installs its fonts in the User 
fonts folder.
 ▶ PowerPoint 2004 presents a “Missing Default Fonts” dialog if some fonts are not 
installed; unfortunately, this dialog appears because one of the missing fonts was 
included with earlier versions of OS X but not more recent versions.

To address the first issue, open the folder /Applications/Microsoft Office 2004/Office/ 
and delete the file Do Fonts. (If you have already run one of the Office applications, you 
should also see Gathering optional fonts on page 9.)

To address the issue with PowerPoint, the first time you see the “Missing Default Fonts” 
dialog select “Don’t show me this again.”

Office 2008 and 2011
Office 2008 and 2011 install fonts in /Library/Fonts/Microsoft/ and move existing fonts 
with conflicting names to /Library/Fonts Disabled/.

These versions of Office do not require any fonts other than System fonts, so you can 
move the Microsoft folder from /Library/Fonts/ to the Optional fonts folder.

Gathering optional fonts
After the above steps, there may be fonts left in the following locations:

/Library/Fonts/
/Library/Fonts Disabled/
~/Library/Fonts/
/Library/Application Support/

Open /Library/Fonts/ and move any files into the Optional fonts folder on the Desktop.

Do the same with files in the /Library/Fonts Disabled/ folder.

Open your User fonts folder; choose Library from the Go menu in the Finder, then open 
the Fonts folder. (On OS X 10.7 Lion and 10.8 Mountain Lion, the User Library folder is 
normally hidden; hold down the Option key when you click the Go menu to reveal the 
Library menu item.)

Select all font files and move them to the Optional fonts folder.

Open /Library/Application Support/. Some software vendors store fonts that they want 
to be accessible to their applications here. For example, on OS X v10.6 and later, Apple 
stores fonts in /Library/Application Support/Apple/Fonts/.

Open the Apple/Fonts/ folder if it is present. You may see a folder named iWork and a 
folder named iOS. The iWork folder contains fonts that are also included with the iWork 
suite of programs; Apple installs fonts here even if you don’t have iWork. The iOS folder 
contains some fonts that are used on the iPhone, iPad, and iPod Touch.

If you have iWork installed, then you should archive the Apple/Fonts/iWork/ folder, 
since those fonts are already installed. (To archive the folder, drag it to the Desktop, 
compress it, and copy the compressed archive to a suitable backup storage medium.)

Copy the iOS and iWork folders to the Optional fonts folder on the Desktop.

Look in the /Library/Applications/ folder for other vendors who may have included a 
Fonts folder and move those fonts to the Optional fonts folder as well. (Skip the Adobe 
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folder if it is present; locating Adobe CS fonts is discussed under Gathering Adobe fonts 
on page 7.)

Prepare to share
We recommend moving your new font folders from the Desktop to the /Users/Shared/ 
folder. This way, the fonts will be available to any user account on your computer, 
present or future.

Upgrade old fonts

While it isn’t always feasible to move clients from using one font to another, there is a 
case to be made for migrating to OpenType fonts when possible:

 ▶ OpenType fonts can include thousands of characters, while PostScript Type 1 fonts 
can only include 256.
 ▶ OpenType fonts can be used on both Macs and PCs, making cross-platform 
document management easier. 
PostScript Type 1 and Classic Mac TrueType fonts can only be used on a single 
platform, and if you open a Mac document that uses these fonts on Windows, 
some characters—like curly quotes—may be mapped to different characters.
 ▶ Most font foundries produce OpenType fonts; some do so exclusively.
 ▶ OpenType fonts use a single file, so installation and management is easier. Older 
PostScript fonts use two files: a screen font and a printer font.

Using your font manager, you can keep legacy fonts available and activate them when a 
project calls for them.

Identifying fonts to upgrade
Open each of the font folders on your Desktop. View the folder as a list, and sort the list 
by Kind. Any of the following font Kinds are candidates for upgrades:

 ▶ Font Suitcase: This Kind can be either a Classic Mac TrueType font suitcase, or the 
bitmap screen font that accompanies a PostScript Type 1 outline font.
 ▶ PostScript Type 1 outline font.
 ▶ TrueType font: This is a Classic Mac TrueType font.

Create a folder on the Desktop named Legacy fonts and move these fonts to it. Make a 
shopping list of these fonts so that you can upgrade them in the future.

Move the Legacy fonts folder to /Users/Shared/ so that it is with all your other font 
folders.

Note: Some of the legacy fonts will be old versions of Core web fonts; compare the 
contents of the Legacy fonts folder with the Core web fonts folder to determine which of 
the legacy fonts you won’t need to upgrade, and remove those from your shopping list.

Adding fonts to your font manager

Important: Before using your font manager, you need to disable some of 
OS X’s built-in font management features.

1. Start Font Book (located in the Applications folder on your hard disk).
2. Choose Font Book > Preferences.
3. Clear the box labeled “Automatic font activation.”
4. Clear the box labeled “Alert me if system fonts change.” 

If there are multiple user accounts on your Mac, you will need to clear 
this setting for each user.

5. Close the Preferences dialog and quit Font Book.

After disabling these features, install your font manager.

The Times, they are a-changin’
So are the Helveticas, the Garamonds, and even 
the Arials. In fact, the past few versions of OS X 
(and Windows, too) have shown a distinct move 
towards using OpenType fonts instead of some 
of the older digital font formats.

Font foundries are embracing this format almost 
exclusively. When you shop for new fonts, you 
will almost definitely be able to find what you 
want in the OpenType bin, while the PostScript 
and TrueType bins have fewer and fewer to 
choose from.

The reasons for this are inherent in the 
construction of OpenType: Adobe and Microsoft 
designed it to combine the features of existing 
font technologies like PostScript and TrueType, 
and expanded it with features needed by digital 
designers, like ligatures, contextual letterforms, 
and most importantly, support for the Unicode 
character set.

For an in-depth comparison of OpenType with 
other font formats, see Appendix D: Font 
formats on page 23.

Disabling OS X font management 
using Terminal
You can use the command line alternative from 
any account (provided you have the system root 
password). The advantage to using this method 
is that the “Alert me if system fonts change” 
setting will be applied to all user accounts, so 
you only need to do this once.

1. Start /Applications/Utilities/
Terminal.app.

2. Type atsutil autoactivation -d and 
press Return. (This disables auto-activation for 
the current user account.)

3. Type sudo atsutil fontprotection 
-off and press Return. (This turns off system 
font alerts for all users.) 
You’ll be prompted for a password; enter the 
password for the root user on the computer and 
press Return again.

4. Type exit and press Return, then quit 
Terminal.
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Where to keep fonts
Font managers will generally have two options for storing fonts: by copying to a private 
folder, or by leaving them in their original folder. There are benefits to both options, and 
usually you can use both simultaneously.

For most of your workflow, we recommend letting the font manager copy fonts to its 
own private folder, and only keeping fonts in their original folders for special cases, 
such as clients who require font segregation, or using fonts on a temporary basis.

Set the default for your font manager to use its private folder. In Suitcase Fusion 4:
1. Choose Suitcase Fusion 4 > Preferences.
2. Under Font Vault Options, select “Copy added fonts to the Vault.”
3. Close the Preferences window.

Note: While these examples use Suitcase Fusion 4 to illustrate processes, most 
font managers will have similar features.

Grouping fonts
In its most basic configuration, your font manager will have two groups of fonts that 
form the basis of your font activity: fonts in the System folders, and fonts outside these 
folders.

OS X restricts what font managers can do with fonts that are in the System fonts folders, 
which is why we had you move most fonts to other folders, so that they can be 
managed easily.

In Suitcase Fusion 4, non-System fonts are listed in a library; the default library is called 
Font Library.

Your font manager should have a way to create sub-groupings of fonts within its 
“library” for easier recognition. (In Suitcase Fusion 4, these groups are called sets.)

We want to create a set for each of the font folders you created earlier (except the 
Legacy fonts folder), then add the fonts from each folder to the set.

In Suitcase Fusion 4, you can create the set and add the fonts for it in one step: drag the 
desired folder from the Finder into the Font Library. Suitcase creates a set with the same 
name as the folder, and adds all the fonts in the folder to the set.

If your font manager has a similar feature, use it; otherwise, make a “set” with the same 
name as each folder, then add the fonts from the folder into the set. (You may need to 
add the fonts to the general “library” first, then move them to the “set.”)

Adding fonts in place
For those times when you don’t want to add fonts to the font manager’s private folder 
(for a quick fix to a job or to keep a client’s fonts segregated from your other fonts), you 
will need to add fonts “in place,” so that the font manager works with them where they 
are.

To add fonts that are managed in place, you will need to switch the setting that tells 
your font manager whether to copy fonts, then add the fonts in question, then switch 
the setting back.

We’ll add a folder of fonts named Big client fonts using this method.

Important: When you add fonts in place, you should be sure to have a backup 
of the fonts first.
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1. Copy the Big client fonts folder to the Desktop or other convenient location.
2. Open Suitcase Fusion 4.
3. Choose Suitcase Fusion 4 > Preferences.
4. Under Font Vault Options, select “Add fonts leaving them in place.”
5. Close the Preferences window.
6. Drag the Big client fonts folder from the Desktop into the Font Library.
7. Choose Suitcase Fusion 4 > Preferences.
8. Under Font Vault Options, select “Copy added fonts to the Vault.”
9. Close the Preferences window.

Suitcase Fusion 4 also allows you to add fonts in place on a temporary basis. To use this 
feature, drag the fonts or folder to the Suitcase Fusion 4 Dock icon. The fonts will only 
be available until you log out of your Mac account, or shut down or restart your 
computer.

This feature allows you to quickly use a set of fonts, such as for a quick job for a client, 
without adding them to the Font Vault and without needing to change your preferences 
temporarily.

Identifying duplicates

The bane of font management is having duplicate fonts. Part of the reason for this is 
that “duplicate” has two different meanings: it can mean two fonts that may have 
different names but identical internal structures, and it can also mean two fonts that 
have the same name yet which may have different metrics, available glyphs, and other 
internal differences.

If you have two fonts with the same name (such as the two Helveticas shown below), 
you probably have different projects that rely on one or the other version. If you delete 
one version, you may end up with a project that looks like the second example: text 
wraps differently and ultimately may cause pagination differences. For this reason, you 
should keep these duplicates but identify each so that you know which is which.

   
A tale of two Helveticas

If you allow your font manager to always keep fonts in its private store (the Font Vault 
in Suitcase Fusion 4), you should never have identical fonts with different names. If you 
do keep some fonts outside the Vault, it is possible that you can see this type of 
duplicate, but it is a minor problem: once identified, all such duplicates can be 
eliminated and will never be a problem again.

Keeping duplicate fonts at bay
The easiest way to deal with duplicate fonts is to 
not let them in. If you use Suitcase Fusion 4 and 
keep your fonts exclusively in the Font Vault, it 
will never add a font that is identical to one that 
is already in the Vault.
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Finding duplicate fonts is relatively easy; in Suitcase Fusion 4, you can use the following 
methods. If you use another font manager, see its documentation.

Finding duplicate fonts by PostScript name
1. Open Suitcase Fusion 4 and click on Font Library.
2. Choose Edit > Find Fonts.
3. In the second line of the Find panel, select Duplicates from the first pop-up 

menu, then select PostScript Name from the second pop-up menu.

The list now shows fonts that have the same PostScript name. If the list is empty, then 
you have no conflicting fonts.

Click the View menu. If Group Fonts by Family is checked, then select it, so that fonts 
are now listed individually and not in folders.

Choose View > Columns > PostScript Name to show the PostScript Name for each font 
listed, then click the header of that column to sort the fonts by their PostScript Name.

Since it is possible that you have used these fonts in projects, you should keep them all, 
but you should find some way to identify each one. For example, you might create 
keywords of your client names, then assign those keywords to the fonts that each client 
uses.

The most important thing to keep in mind with duplicate PostScript names is that only 
one of these fonts can be active at a time. The result is that font substitutions will occur 
if the wrong font is active.

Font managers include activation plug-ins for professional design applications to 
ensure 100% accuracy. Global activation techniques are used to ensure correct font 
usage in other applications such as word processors and spreadsheets.

Finding identical duplicates
This method is possible because Suitcase assigns a unique Font Sense ID to each font 
based on internal font information. The only way that two fonts will be assigned the 
same Font Sense ID is if those two fonts are identical.

1. Open Suitcase Fusion 4 and click on Font Library.
2. Choose Edit > Find Fonts.
3. In the second line of the Find panel, select Duplicates from the first pop-up 

menu, then select Font Sense ID from the second pop-up menu.

The list of fonts below the Find panel now shows all fonts that have identical Font 
Sense IDs. If the list is empty, then you have no identical fonts.

Note: The only way that you could have identical fonts in Suitcase Fusion 4 is 
if you add fonts in place. When you keep your fonts in the Font Vault, Suitcase 
scans each font when you add it and won’t allow duplicates.

Click the View menu. If Group Fonts by Family is checked, then select it, so that fonts 
are now listed individually and not in folders.

Choose View > Columns > Font Sense to show the Font Sense ID for each font listed, 
then click the header of the Font Sense column to sort the fonts by their Font Sense ID.

You can now select one of each identical font, then choose Edit > Delete from Library to 
remove the identical font permanently.

What’s in a (PostScript) name?
A font’s PostScript name is an internal value 
that the system and applications use to identify 
and activate fonts.
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Conflicting System fonts
There is another issue involving some fonts that have identical PostScript names. Some 
of OS X’s System fonts—including some required fonts—have the same PostScript name 
as their Adobe Type 1 PostScript counterparts.

Some of these fonts are easily dealt with: Courier.dfont, Symbol.dfont, and Times.dfont 
are not protected by the OS and so can be easily disabled if necessary.

Helvetica.dfont and HelveticaNeue.dfont, however, are protected fonts: If you remove 
them, the OS replaces them from a hidden repository. (Under OS X versions 10.6.5 
through 10.6.8, HelveticaLight.dfont and HelveticaLightItalic.dfont are also protected.)

Since the OS must have some version of these fonts active in order to run properly, it 
can be difficult to disable them in favor of their Adobe PostScript counterparts. It can be 
done manually, but this requires some modifications to your OS that, if done 
incorrectly, could leave your system unusable.

A good solution would be to replace your Adobe Type 1 fonts with their OpenType 
counterparts. This FAQ from Adobe can help you determine what changes may have 
been made to the fonts you are concerned about: http://www.adobe.com/type/
opentype/T1_to_OTF_FAQ.htm. Before upgrading to OpenType fonts, you should 
definitely check with clients that rely on these fonts; intervening changes in the fonts 
may affect a client’s documents.

Suitcase Fusion 4 allows you to override System fonts that conflict with your PostScript 
Type 1 fonts. Suitcase works in the background to make sure that the System fonts are 
not displayed in applications’ Font menus.

However, since Apple has not shown any signs of changing these fonts (some would 
say “correcting” them), you should work towards a long-term goal of having your 
clients upgrade to OpenType fonts.

Finding corrupt fonts

A corrupt font is any font where the font resources can’t be opened, the font resources 
contain inconsistent information, or there is incorrect values in important fields.

Fonts can be created with inconsistent font information, or can be corrupted 
accidentally, such as by moving a Mac PostScript font to a Windows system (see the 
sidebar “The fork in the road” on page 23).

A good font manager will scan fonts as you add them and identify and reject or 
quarantine any corrupt fonts that it finds.

However, if you are experiencing problems that lead you to believe that one of your 
fonts has been corrupted, use your font manager or a font utility like FontDoctor to scan 
your fonts.

Scanning fonts with Suitcase Fusion 4
1. Select a font, set or library to scan.
2. Choose File > Check for Corruption.

Any corrupt fonts are placed into a new set within the selected library.

Scanning fonts with FontDoctor
If your font manager doesn’t scan fonts for corruption, you can use a font utility like 
FontDoctor or Font Book (included with OS X).

The Doctor is In
FontDoctor is included with Suitcase Fusion 4 
and is available separately from Extensis at 
http://www.extensis.com/fontdoctor.

http://www.adobe.com/type/opentype/T1_to_OTF_FAQ.htm
http://www.adobe.com/type/opentype/T1_to_OTF_FAQ.htm
http://www.extensis.com/fontdoctor
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FontDoctor offers many options over other font utilities, including the ability to move 
corrupt or conflicting fonts and clean font caches.

See the FontDoctor help system for details on how to use it to diagnose font problems.

Scanning Fonts with Font Book
Font Book, the font manager included with OS X, can scan fonts for corruption without 
the need to install them first.

1. Open Font Book.
2. Choose File > Validate File.
3. Select one or more font files to scan and click Open.

Font Book performs an exhaustive scan on each font and reports any errors.

Be forewarned: Font Book will not scan PostScript outline font files, and it will also 
report fonts that are duplicates of installed fonts.

Planning for more fonts
Let’s not kid ourselves: there is no such thing as “enough fonts.” You are going to get 
more, and it is a good idea to be ready for them.

Where fonts come from

You usually get fonts in one of two ways: by purposefully acquiring them singly or in 
bunches, or by finding them installed along with a new piece of software.

Purchased fonts

When you purchase or download fonts, you should keep certain things in mind:
 ▶ Purchase or download from reputable foundries or websites.
 ▶ Don’t bother with fonts in old formats (fonts for Mac OS 9 or Windows 95, for 
example).
 ▶ Try to get fonts in OpenType format (unless a client or job calls for a font in a 
specific format, and even then, question their need and explain the benefits of 
OpenType).
 ▶ Be wary of collections of thousands of fonts for a low price. They are often mostly 
display or “fun” fonts that you will rarely use, and are not of high typographic 
quality.
 ▶ Make sure the fonts you acquire include the styles, languages, and symbols that 
you need.

Before you add new fonts to your font manager, make a backup copy, then scan them 
for corruption. (Suitcase Fusion 4 and other font managers scan fonts as you add them, 
so you may not need to scan them separately.)

After you add the fonts to your font manager, double-check to make sure there aren’t 
duplicate fonts by PostScript name. If your font manager supports sets, you may want 
to add new fonts as a set so that, if you need to remove any, they are already identified.

Add keywords or other unique identifying information to new fonts. If they were 
purchased specifically for a client or job, add that information as a keyword.
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Fonts included with applications

Some applications, such as the Adobe Creative Suite, include high quality fonts for your 
use.

However, you may not have any options regarding font installation. The software may 
install fonts in your System font folders or in other locations where your font manager 
has less control over them.

Before installing new software, you may want to make it easier to identify which fonts 
“belong” in your System folders (the fonts that you purposely left there), so you can 
easily move those that don’t.

Note: The following process is optional. It can help you identify fonts that get 
installed along with other software you install, but is not absolutely necessary. 
If you don’t follow these steps, future installed fonts will typically show up in 
your System fonts.

List your current fonts
A simple and safe method of identifying System fonts is to make a list of them.

1. Open the /Library/Fonts/ folder.
2. Choose View > As List.
3. If you are using OS X Lion or Mountain Lion, choose 

View > Arrange By > None.
4. Click the heading of the Name column to sort the files by name.
5. Choose Edit > Select All.
6. Hold down the Option key and choose File > Show Inspector.
7. In the Multiple Item Info window, make a note of how many files are present 

(shown next to Kind at the top of the window).
8. Close the Multiple Item Info window and choose Edit > Copy.
9. Open TextEdit and create a new document.
10. Type Library Fonts: ### files and press Return. Instead of ###, type the 

number of fonts as shown in the Multiple Item Info window.
11. Choose Edit > Paste and Match Style. 

If you choose Paste, TextEdit will paste all the copied fonts into your 
document; choose Undo and try again.

12. Save the file in your Documents folder. Name it “Library Fonts as of” and 
append the date to the filename (such as, Library Fonts as of 27 July 2012.rtf).

Repeat the above process for the /System/Library/Fonts/ folder; name the resulting file 
“System Library Fonts as of” with the date appended to the filename.

Collecting fonts installed by an application
If an application doesn’t give you options regarding installing fonts, it may install them 
in one of several places: one of the System font folders, the Application Support folder, 
or someplace else.

For details about finding and relocating fonts installed in the Application Support 
folder, see Gathering optional fonts on page 9.

If you suspect your application has installed fonts but you cannot find them, see the 
documentation that came with the software; sometimes fonts will be placed in a 
separate folder inside the application’s folder.

Some applications that install fonts into a System folder add them into a folder of their 
own; Microsoft Office 2008 and 2011 install their fonts into a folder named Microsoft. 
Removing these fonts is as simple as dragging this folder out of the Fonts folder.

Using labels instead of lists
Working from lists of your System fonts is usually 
adequate for identifying fonts installed by other 
applications. It can be tedious and doesn’t 
account for the possibility that an application 
might replace a system font with its own. 
(Microsoft Office moves fonts it replaces into 
/Library/Fonts Disabled/).

If you want to be a little more sure of your 
System fonts, you can use the Finder’s built-in 
color labels to identify the fonts that belong. 
Since this involves changing file permissions, it is 
not a task to be undertaken lightly.

For details, see Appendix E: Color-coding fonts 
on page 26.
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To collect fonts that are installed in the System font folders:

1. Make a new fonts folder on your desktop, named for the application you just 
installed (such as SurfWriter fonts). This is where you will move the fonts that 
the new application installed.

2. Open the Library Fonts list document that you saved in your Documents folder.
3. Open the /Library/Fonts/ folder and compare the number of files present with 

the number that you recorded at the top of your Library Fonts list. 
(To quickly count the fonts in the older, choose View > Show Status Bar; the 
status bar at the bottom of the window shows how many files are in the 
folder.) 
If the number is the same, then there are probably no new fonts and you can 
move on to checking the next folder. (It is unlikely but possible that the 
application removed some fonts and added others.)

4. If the number of fonts present is different from the number you recorded, then 
you should review the list against the folder contents. When you find a font in 
the folder that is not on your list, remove it to the folder that you created on 
the desktop (SurfWriter fonts in our example).

5. Open the System Library Fonts list that you saved earlier.
6. Open the /System/Library/Fonts/ folder. (Applications shouldn’t be installing 

fonts here, but it is a good idea to check just to make sure.) Check the folder 
against the list; if there are fonts here that are not on your list, select them and 
then choose File > Move to Trash. Enter your password at the prompt. Move 
the fonts from the Trash into the new application’s fonts folder on the desktop.

7. You should also check whether the application installed fonts in your User 
fonts folder. Choose Go > Library in the Finder, then open the Fonts folder. (On 
OS X Lion and Mountain Lion, hold down the Option key while clicking Go to 
see the Library option on the menu.) Select all the fonts in this folder and 
move them to the application’s fonts folder on the desktop.

8. Move the new application fonts folder (SurfWriter fonts in our example) into 
the /Users/shared/Optional fonts/ folder

Font caches

In computer parlance, a cache is an easily-accessed store of frequently-used data. 
Microprocessors have a cache (or more than one) that it uses to quickly load 
instructions to execute, hard disk drives have caches so they can access a large block of 
data quickly, and many applications use a cache to quickly load frequently used data.

The Mac OS and many font-intensive applications use a cache for font data. This allows 
the OS and applications to use less dedicated memory. Instead, they will load font data 
from the cache when it is needed, then discard it when finished.

Any cache data can get out of synch, or “stale.” If you start experiencing problems with 
fonts, either seeing garbled text on screen or experiencing slowdowns related to font 
changes, then you may want to clean your font caches.

The easiest way to do this is to use a cache cleaning utility. This is a feature of both 
Suitcase Fusion 4 and FontDoctor. Either will clean the caches of your operating system 
and major design software, then restart your computer.

You can also clean system and application font caches manually; see Appendix C: 
Clearing font caches manually on page 21 for instructions.

It never ends
Effective font management is an ongoing task. However, by choosing the right tools and 
implementing some basic processes, it can become a seamless part of your creative 
workflow, and can even add benefits that you hadn’t imagined possible.



18

OS X Font Management
Appendix A: Font terminology
Some of the terminology used when talking about computer fonts can be confusing, 
often because some terms are used interchangeably, or are used differently by different 
companies. For a more complete glossary of type-related terms, see Adobe’s website at 
http://www.adobe.com/type/topics/glossary.html.

Here are some common terms and what we mean when we use them.

Traditional typographic terms

character
A single letter, punctuation mark, number, space, or any other object or symbol in a 
font. Compare with glyph.

family
A collection of related typefaces that were designed and intended to be used together. 
Typefaces in a family will vary in weight, style, or width, but not in overall design.

The Myriad Pro family of 10 typefaces

font
A complete set of characters of a single typeface in one weight, width, and style. Times 
New Roman Italic is a font, as is Garamond Semibold.

glyph
The visual presentation of a character. A single character, such as the capital letter A, 
can have different glyphs in different fonts. Glyphs do not need to represent characters 
used for text (as seen in the multitude of dingbats fonts available), and in some non-
Roman writing systems, a single character can be represented by multiple glyphs within 
a single font.

Same character, different glyphs 
(Rockwell Extra Bold, Lithos Pro, Edwardian Script ITC)

style
A variation in appearance (such as bold or italic) that constitutes a typeface in a family 
of typefaces. 

typeface
The collection of glyphs that constitute a design of type. A typeface is usually part of a 
family of related designs. A typeface’s name includes the family name and a style 
designation, such as italic or condensed.

http://www.adobe.com/type/topics/glossary.html
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Computer typographic terms

bitmap font
A bitmap font is made up of images of each glyph. Each glyph image is a matrix or 
bitmap of pixels representing the glyph for a single face, style, weight, and size. Bitmap 
fonts are designed for a specific output resolution, typically a screen resolution. Bitmap 
fonts do not scale well, since their size is fixed. Compare with outline font.

12-point bitmap, 24-point bitmap, 12-point scaled to 24-point

font file
Any file containing one or more fonts that the computer can display directly.

outline font
An outline font (also called a scalable font or vector font) is a set of instructions that 
describe how to draw each glyph in the font. Outline fonts can be scaled to virtually any 
size for any type of device without loss of quality.

An outline font (Times New Roman) at multiple sizes

An outline font rasterized at 72 dpi, 96 dpi, 300 dpi, and 600 dpi

When size mattered
In early versions of the Classic Mac OS, bitmap 
fonts were usually shipped in 9, 10, 12, 14, 
18, and 24-point sizes to accommodate most 
writing needs. If you tried to use a different size, 
the Mac OS would scale an existing bitmap. The 
results were often blocky and unreadable.

When is an outline not an outline? 
When it’s a bitmap.
Since most output devices are pixel-oriented 
(such as displays, laser printers, and inkjet 
printers), a bitmap representation of a glyph 
must be generated at the correct size in order to 
be displayed or printed. This is done by the 
operating system or by a printer’s page layout 
engine in a process called “rasterizing.”
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Appendix B: The User Library under Lion and Mountain Lion
In OS X 10.7 (Lion) and 10.8 (Mountain Lion), the Library folder inside your home folder 
(~/Library/) is hidden from casual snoopery, but easily unveiled.

To open the folder, in the Finder, hold down the Option key, click the Go menu, then 
choose Library.

If you hold the Go menu open and release the Option key, you’ll see the Library menu 
item disappear. Press Option, and it reappears.

This is important because you will sometimes need to check the User fonts folder 
(~/Library/Fonts/) to see if there are fonts installed there.

You can also open the User fonts folder directly; choose Go > Go to Folder, type the 
folder path (~/Library/Fonts/) and press Return.

If you share your computer with other users, you may sometime need to examine the 
fonts in their User fonts folder. For example, if there is a user named Joe, you may want 
to look in /Users/Joe/Library/Fonts/. There are two problems: by default you won’t have 
access to Joe’s user folder, and Joe’s Library folder is hidden also.

The easiest way around this is to have Joe log in, do what you need, then log out.

Another way to gain ready access to another user’s Library folder is to give yourself 
read/write permissions on the user’s home folder and all its contents, then unhide his 
Library folder as above. Since this involves changing file permissions for a user’s entire 
account directory, we won’t spell out how to do that here. If you are wise in these 
things, you can pretty quickly do this on your own; otherwise, we don’t want to tempt 
you.

This Library never closes
If you are tired of the hidden Library folder, you 
can show it permanently. Open Terminal, type 
chflags nohidden ~/Library and press 
Return. If you want to re-hide the folder at some 
point, go back to Terminal and enter chflags 
hidden ~/Library.
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Appendix C: Clearing font caches manually
If you don’t have a utility that will clear font caches, or if you just want to experience it 
once for yourself, here are instructions for clearing the font caches for OS X, Adobe 
applications, QuarkXPress, Microsoft Office, and iWork.

Cleaning the system font cache

OS X includes a command line utility for cleaning the system font cache. To use the 
utility, you need to log in with an administrator account.

1. Close all applications. (Important!)
2. Start Terminal (located in the Utilities folder; press Command-Shift-U to open 

this folder).
3. Type sudo atsutil databases -remove and press Return.
4. Type your password at the prompt (no characters will echo back to the screen).
5. When the process is complete, type exit to end your command line session, 

choose File > Quit to exit Terminal, then restart your Macintosh.

Cleaning Adobe font caches

If your font display problems are limited to Adobe applications, it may be due to a 
corrupt Adobe-specific font cache.

The different versions of Adobe applications create font caches with various names in 
several locations. Rather than exhaustively list the possible names and locations for 
Adobe font caches, it is simpler to use the Find feature of the Mac OS X Finder to locate 
these files for you, then delete them.

The following steps set up the Finder so you can locate files in System folders that are 
not normally included in Find operations.

1. In the Finder, press Command-N to open a new window.
2. Press Command-F.
3. Click the pop-up menu that shows Kind and choose Other. 

4. Scroll down the list of search attributes to System files, check the box in the 
In Menu column, and click OK.

These steps add the System files option to the pop-up search menu. You will only need 
to perform these steps once; after this, the System files option will always be in the 
pop-up menu.

To remove Adobe font caches:
1. Quit all Adobe applications.
2. Open a new Finder window.
3. Press Command-F.
4. Click This Mac in the Search bar.
5. Choose System files from the first pop-up menu, then choose Are included 

from the second pop-up menu.
6. Click the  button at the end of the “System files are included” criterion.
7. Choose Name from the first pop-up menu, then choose contains from the 

second pop-up menu, then type fnt into the field.
8. Click the  button at the end of the “Name contains fnt” criterion.

Safe Mode
Starting your Mac in Safe Mode will also clear 
most system font caches. The catch is that you 
will have to restart your Mac twice to complete 
the process.

For details, see the Apple support article Mac 
OS X: Starting up in Safe Mode (http://
support.apple.com/kb/HT1455).

http://support.apple.com/kb/HT1455
http://support.apple.com/kb/HT1455
http://support.apple.com/kb/HT1455
http://support.apple.com/kb/HT1455


22

OS X Font Management
9. Choose Name from the first pop-up menu, then choose ends with from the 

second pop-up menu, then type .lst into the field. 

 
Tip: Click Save in the Search bar to quickly perform this search again.

10. When the search is complete, select the files in the list whose name start with 
Acro, Adobe, and Illustrator and move them to the Trash, then empty the 
Trash.

The next time you open the affected Adobe application, it will automatically create new 
clean copies of the font cache files.

Deleting the QuarkXPress JAWS Font Cache

QuarkXPress uses the JAWS PDF generation engine to create PDF files from documents. 
This PDF creation engine places cache files on your system that can become quite large 
and cause stability issues. To prevent or resolve these issues, you can clear the JAWS 
folder. QuarkXPress will automatically regenerate any necessary files.

To clear the JAWS folder:
1. Close all Quark applications.
2. Remove the contents of the following folder based on the version of 

QuarkXPress installed. 
QuarkXPress 7.1 and newer store the cache in each user’s home folder: 
 ~/Library/Preferences/Quark/QuarkXPress 7.0/jaws/ 
 ~/Library/Preferences/Quark/QuarkXPress 8/jaws/ 
 ~/Library/Preferences/Quark/QuarkXPress 9/jaws/ 
Versions earlier than QuarkXPress 7.1 store the cache in the Application folder: 
 /Applications/<QuarkXPress folder>/jaws/ttfont/

3. Start QuarkXPress.

Microsoft Office font cache

If Microsoft Office applications crash or freeze, display font corruption warnings, run 
slowly, or if you have font menu problems, then you may need to manually clear the 
Office font cache.

1. Close all Microsoft Office applications.
2. Depending upon your version of Office, remove the following files: 

 ~/Library/Preferences/Microsoft/Office Font Cache (11) 
 ~/Library/Preferences/Microsoft/Office 2008/Office Font Cache (12) 
 ~/Library/Preferences/Microsoft/Office 2011/Office Font Cache

3. Open the affected Office application.

Apple iWork font cache

If one of the applications in Apple’s iWork suite is crashing after picking a template or 
clicking in an editable field, clearing the iWork font cache can help.

1. Close all iWork applications.
2. Move the following file to the Trash: 

 ~/Library/Caches/com.apple.iwork.fonts
3. Open the affected iWork application.
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Appendix D: Font formats
As computers and their typographical output has become more sophisticated, so have 
the fonts they use. The original Mac wowed us with black-and-white bitmap fonts at 72 
dots per inch; today’s retina displays, interactive animated websites, and million-color 
printers require much more.

OpenType (.otf or .ttf)
OpenType is the format that OS vendors are standardizing on. The file format is based 
on the Windows version of TrueType, but an OpenType font can contain outline data in 
PostScript format (such files use the extension .otf) or TrueType format (using either the 
extension .ttf or .otf). This means that professional publishing environments can 
continue to use PostScript outlines if they are so inclined.

There are several advantages to OpenType. As with TrueType fonts, one font is one file. 
OpenType font files are cross-platform: the same file can be used on a Mac or Windows 
system with consistent results. An OpenType font can contain thousands of glyphs. Not 
only can this enable extensive language support in a single font, but ligatures, swashes, 
true small caps, and other advanced typographical alternate glyphs can be built into a 
font, and are accessible in compatible applications. Finally, OpenType fonts are based 
on Unicode, the universal cross-platform character encoding standard. These are 
significant benefits over PostScript Type 1, which is limited to 256 encoded characters, 
and does not directly support Unicode. Font vendors often offer information on 
compatibility or upgrade availability, such as this FAQ from Adobe: http://www.adobe.
com/type/opentype/T1_to_OTF_FAQ.htm.

OS X natively supports OpenType fonts and Unicode information, making OpenType an 
excellent choice for new font purchases. However, unless your budget allows for 
re-licensing all your existing fonts, you may want to migrate only gradually, as you 
cannot simply convert your existing PostScript Type 1 or TrueType fonts to OpenType 
and get the same results as with freshly licensed OpenType fonts. Most font vendors 
now sell OpenType versions of their font collections, and some are developing only 
OpenType fonts at this point.

Composite Fonts (.sfont)
OS X 10.8 Mountain Lion includes support for a new ISO font standard, the Composite 
Font Representation (CFR).

OpenType fonts can only include some 65,000 glyphs, but the Unicode standard defines 
over 100,000 characters (roughly 75,000 of these are CJK Unified Ideographs).

The new standard specifies a way to concatenate glyphs from multiple fonts into one 
“super-font.” An application that supports CFRs can simultaneously display all glyphs in 
the composite font.

But the CFR doesn’t stop there. It also defines fallback fonts for the various components 
of the CFR, so that if one of the component fonts isn’t present, glyphs from another font 
can be used instead. (This is analogous to the notion of the fallback stack used in CSS by 
web designers, where a web page specifies one or more fonts to “fall back” on if the 
original designer’s choice isn’t available on the system viewing the web page.)

So far, CFRs are only supported by some of Apple’s applications (notably, TextEdit). As of 
this August 2012, they are not yet supported by Microsoft Office, Adobe Creative Suite, 
any font managers, or most other applications. Whether and how quickly this changes 
remains to be seen. (The ISO standard was published on April 17, 2012.)

The fork in the road
Legacy Macintosh fonts, specifically PostScript 
Type 1 fonts and Classic TrueType fonts, are in 
files that include important data in a separate 
resource fork. With the advent of OS X, Apple 
has been moving away from resource files.

The most important thing to remember about 
these types of fonts is that the resource forks will 
not be recognized by Windows or any other 
operating system. If you copy or move these fonts 
to a Windows system or onto a Windows server, 
the copied files will not include the resource fork 
and will no longer be usable on your Mac.

Note: If you do need to store your fonts on a 
Windows server or backup system, they will be 
perfectly safe if you archive them in a .ZIP file 
first. To create an archive in OS X, choose a file 
or folder, then choose File > Compress “item 
name”.

OpenType wraps it up
The OpenType format was designed by Adobe 
and Microsoft so that it could be a wrapper 
around fonts in either the TrueType or PostScript 
Type 1 format. Your font manager may 
differentiate these as OpenType-TT or 
OpenType-PS, indicating which type of font is 
at the core of the OpenType file.

http://www.adobe.com/type/opentype/T1_to_OTF_FAQ.htm
http://www.adobe.com/type/opentype/T1_to_OTF_FAQ.htm
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Adobe provides an interesting synopsis of CFRs in Mountain Lion, along with a 
downloadable example.

 ▶ CJK Type / CFR Support in Mac OS X Version 10.8 (http://blogs.adobe.com/
CCJKType/2012/07/cfr-support-in-mountain-lion.html)
 ▶ CJK Unified Ideographs (http://en.wikipedia.org/wiki/CJK_Unified_Ideographs)

TrueType (.ttf)
Mac OS X also supports TrueType fonts with the .ttf extension, which are a cross-
platform format originally developed for Windows. Beginning with Mac OS X v10.6, 
many Mac system fonts are in this format. These fonts are roughly equivalent to Classic 
Mac TrueType fonts, but with a different file structure (they lack the resource fork and 
its associated data, or that data is placed inside a special table within the data fork). 
Each .ttf file is a single, complete TrueType font.

Originally, TrueType fonts were not as widely accepted in professional creative, print, 
and publishing environments. However, most TrueType fonts will function properly in a 
professional workflow.

TrueType Collection (.ttc)
TrueType Collection files contain multiple .ttf fonts in a single file. TrueType Collections 
allow multiple fonts to share glyphs or other tables, and can create a significant saving 
of file space. Windows typically uses TrueType Collections for East Asian languages, 
while OS X uses them for many purposes. Although this format was originally 
developed for Windows, beginning with Mac OS X v10.6, many Mac system fonts are in 
this format. Older versions of OS X have less well developed support for .ttc fonts.

Mac PostScript Type 1 
These were long the de-facto standard for professionals in creative, print, and 
publishing environments.

Each PostScript Type 1 font is made up of two parts, a suitcase font file containing 
bitmaps and metrics (sometimes called the “screen font”) and the corresponding 
outline font file (sometimes called the “printer font”). Both the suitcase and 
corresponding outline files must be in the same physical folder in order to work 
properly in OS X. Note that one suitcase file may contain the bitmaps and metrics for 
multiple outline fonts. (Older PostScript fonts sometimes also included a separate font 
metrics file with the .afm extension. This was generally extraneous.)

Mac PostScript Type 1 fonts have resource forks, which can be an issue for file transfer 
and backup/restore.

PostScript Type 1 fonts for Windows systems are not compatible with OS X.

Datafork Truetype font (.dfont)
With OS X, Apple introduced a new way of packaging system fonts. The .dfont is a font 
suitcase with TrueType font data stored in the file’s data fork rather than the resource 
fork. Apple’s .dfont fonts are generally high-quality fonts, but this format is only used 
by Apple. Unlike other new font formats, the .dfont format only works on OS X, and 
equivalent Windows fonts are not often available; therefore these fonts should be 
avoided in any potentially cross-platform workflows (for example, if your printer or 
service bureau is doing output from Windows).

Apple Advanced Typography (AAT)
Apple Advanced Typography (AAT) is an alternative to OpenType for encoding advanced 
typographic information in a font. AAT features may be coded in a Mac or Windows 
TrueType font, a .dfont, or an OpenType font. Many Apple system fonts have AAT 
features for advanced typography. Such features are accessible only in AAT-savvy 
applications. Few vendors other than Apple have created AAT fonts, and other than 

Using Windows Type 1 fonts on a Mac
Windows PostScript Type 1 fonts are not natively 
supported by Mac OS X, and so are not 
managed by Mac font managers.

Adobe, the inventor of PostScript and PostScript 
fonts, knows a thing or two about the subject.

Adobe design applications on the Mac will let 
you use Windows PostScript fonts just as if they 
were Mac fonts. You only need to copy the font 
files to the folder /Library/Application 
Support/Adobe/Fonts/. If this folder doesn’t 
exist, go ahead and create it.

Windows PostScript fonts are comprised of two 
files with the same base name, one with the 
extension .pfb and the other with the extension 
.pfm. Copy both files to the above folder in order 
for your applications to recognize the font.

InDesign and .dfonts
Several Apple system fonts share names with 
fonts commonly used in publishing. These fonts 
would often override their PostScript 
counterparts that are usually more desirable in 
published output. Adobe realized this and made 
InDesign automatically ignore a system .dfont if 
its PostScript version was installed and active. 
This worked well until Mac OS X v10.6 replaced 
the HelveticaNeue.dfont with 
HelveticaNeue.ttc, a TrueType collection. 
Suddenly InDesign users were back in the same 
situation, where their PostScript font was being 
overridden by a system font. Apple graciously 
returned the .dfont version in a subsequent 
update to Snow Leopard.

http://blogs.adobe.com/CCJKType/2012/07/cfr-support-in-mountain-lion.html
http://blogs.adobe.com/CCJKType/2012/07/cfr-support-in-mountain-lion.html
http://blogs.adobe.com/CCJKType/2012/07/cfr-support-in-mountain-lion.html
http://en.wikipedia.org/wiki/CJK_Unified_Ideographs
http://en.wikipedia.org/wiki/CJK_Unified_Ideographs
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Apple’s own iWork applications (such as Pages and Keynote), few major applications 
support AAT typographic capabilities. 

Classic Mac TrueType 
Classic Mac TrueType fonts consist of a “suitcase” file that contains outlines and 
(optionally) bitmaps, as well as all the required font metrics. The fact that all required 
font information is in one file makes them easier to use than PostScript Type 1 fonts. A 
single TrueType font suitcase can contain many TrueType fonts. TrueType fonts can 
contain thousands of glyphs, enabling extended language support in a single font.

A TrueType font suitcase has a resource fork, which can be an issue for file transfer and 
backup/restore. Because of this, and because most Classic fonts use Mac-specific 
character encoding, these fonts can’t be used on Windows systems.

Multiple Master
This special kind of PostScript Type 1 font allows modifications of one or more font 
parameters to create variations of the original font, such as varying weight or width. 
While multiple master (MM) fonts are supported by Mac OS X v10.2 and later, they are 
no longer sold or supported by Adobe, the original creator of the format. Uneven 
support for MM fonts has been known to cause various issues and problems in 
professional workflows, so we recommend not using them, if possible. Adobe has made 
OpenType equivalents of all its former MM fonts so there are alternatives available: 
http://www.adobe.com/type/browser/mmoffer.html.

Since Mac Type 1 Multiple Master fonts have resource forks, they are subject to problems 
that may arise during transfer or backup/restore.

As with regular PostScript Type 1 fonts, there is a separate Windows flavor of MM fonts. 
Windows MM fonts are not supported on OS X.

For more details on font formats, see the following:
 ▶ Mac OS X: Font file formats (http://support.apple.com/kb/TA22195)
 ▶ Adobe - Fonts: Type topics: Font formats (http://www.adobe.com/type/topics/
info9.html)
 ▶ Font Formats (http://www.adobe.com/type/browser/info/formats.html)
 ▶ OpenType fonts | the font format and its usage (http://www.prepressure.com/
fonts/basics/opentype) 
The sidebar on this Prepressure.com page links to other articles on font formats.

A Classic Case of Fonts
Well before OS X came along, the Mac OS 
stored fonts in files called “suitcases.”  A font 
suitcase could contain any mix of TrueType and 
bitmap fonts, and they didn’t even have to be 
related. (The suitcase originated with Mac 
System 1.0 in 1984; TrueType fonts didn’t 
come around until System 7 in 1991.)

Although the classic Mac OS did not require 
extensions to identify file types, people often 
added the extension .suit for TrueType or mixed 
suitcase files, and .bmap for suitcases that 
contained only bitmap fonts.

OS X can still use TrueType fonts designed for 
the Classic Mac OS. However, it is a good idea to 
use more modern fonts in new projects; most 
Classic fonts do not use Unicode encoding and 
do not include more than 256 characters.

http://www.adobe.com/type/browser/mmoffer.html
http://support.apple.com/kb/TA22195
http://support.apple.com/kb/TA22195
http://www.adobe.com/type/topics/info9.html
http://www.adobe.com/type/topics/info9.html
http://www.adobe.com/type/topics/info9.html
http://www.adobe.com/type/browser/info/formats.html
http://www.adobe.com/type/browser/info/formats.html
http://www.prepressure.com/fonts/basics/opentype
http://www.prepressure.com/fonts/basics/opentype
http://www.prepressure.com/fonts/basics/opentype
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Appendix E: Color-coding fonts
The OS X Finder makes it relatively easy to label files with a color, so that you can 
visually differentiate them. Labeling System fonts is a little more cumbersome since 
you don’t normally have permission to change those files. The following steps show you 
how to modify the permission that allows you to change the file, apply a color label, 
then reset the permission.

1. Open the /Library/ folder and select the Fonts folder.

2. Choose File > Get Info, then click the lock icon  at the bottom of the Info 
window. Enter your password at the prompt.

3. Under Sharing & Permissions, click in the Privilege column next to everyone, 
then choose Read & Write from the pop-up menu. 

4. Click the Action pop-up menu  and choose Apply to enclosed items. In the 
confirmation dialog, click OK.

5. Close the Fonts Info window, then open the Fonts folder.
6. Press Command-A to select all the fonts.
7. Choose a label color from File menu. All the files should have the color applied.
8. Click the back arrow  at the top of the Fonts window to return to the 

/Library/ folder.
9. Select the Fonts folder and press Command-I to open the Info window again.
10. Click the lock and enter your password.
11. Set the Privilege for everyone to Read Only, then choose 

Apply to enclosed items from the Action menu.

Perform the same steps on the fonts in /System/Library/Fonts/.

By using this method, you can collect and manage all the fonts installed by other 
applications, and you can also identify fonts installed by new applications in the future.

Whenever you update your system software, be sure to check the fonts in 
/Library/Fonts/ and /System/Library/Fonts/; if any have been added or updated they 
will not have a label, so follow the above steps to apply the label color to the new fonts.

Collecting fonts installed by an application
1. Make a new fonts folder on your desktop, named for the application you just 

installed (such as SurfWriter fonts). This is where you will move the fonts that 
the new application installed.

2. Open the /System/Library/Fonts/ folder. (Applications shouldn’t install fonts 
here, but it is a good idea to check just to make sure.) If there are fonts here 
that do not have the color label that you applied, select them and then choose 
File > Move to Trash. Enter your password at the prompt. Move the fonts from 
the Trash into the new application’s fonts folder on the desktop.

3. Open /Library/Fonts/ and move any unlabeled fonts into the new application’s 
fonts folder.

4. You should also check your User fonts folder for application fonts. Choose 
Go > Library in the Finder, then open the Fonts folder. (On Lion and Mountain 
Lion, hold down the Option key to see Library on the menu.) Select all the 
fonts and move them to the application’s fonts folder on the desktop.

5. Move the new application fonts folder (SurfWriter fonts in our example) into 
the /Users/shared/Optional fonts/ folder.

Permissions warning
Be careful when changing permissions on 
folders and files, especially in the 
/System/Library/ folder. The process described 
here is useful but optional; nobody will laugh at 
you if you don’t have fancy colored font files.
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